# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<a>[^\ \ ]*)(?:\()(?<b>[^\)]*)(?:\))/SUM/gm;t' <<< "5 * 6 + set(asdsa.sadassa.$asdsadsa) + 5 + avg(asdsad) + 5"