use strict;
my $str = '5 * 6 + set(asdsa.sadassa.$asdsadsa) + 5 + avg(asdsad) + 5';
my $regex = qr/(?<a>[^\ \ ]*)(?:\()(?<b>[^\)]*)(?:\))/mp;
my $subst = 'SUM';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";