import Foundation
let pattern = #"^(sip[s]?:|tel:|)(\+82)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"sip:+82"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\x30\x32$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)