// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(sip[s]?:|tel:|)(\+82)(.*)").unwrap();
let string = "sip:+82";
let substitution = "$1\\x30\\x32$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}