use strict;
my $str = 'sip:+82';
my $regex = qr/^(sip[s]?:|tel:|)(\+82)(.*)/mp;
my $subst = '$1\\x30\\x32$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";