re = /^(sip[s]?:|tel:|)(\+82)(.*)/m
str = 'sip:+82'
subst = '$1\\x30\\x32$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result