import Foundation
let pattern = #"(\().*(.*)[ ]?==[ ]?null[ ]?\|\|[ ]?(.*).length\(\)[ ]?==[ ]?0"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(companyId != null && companyId.length() > 0 )
(companyId != null && companyId.length() > 0 )
(campaignId == null || campaignId.length() == 0)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1StringUtils.isBlank($3)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)