use strict;
my $str = '(companyId != null && companyId.length() > 0 )
(companyId != null && companyId.length() > 0 )
(campaignId == null || campaignId.length() == 0)';
my $regex = qr/(\().*(.*)[ ]?==[ ]?null[ ]?\|\|[ ]?(.*).length\(\)[ ]?==[ ]?0/p;
my $subst = '$1StringUtils.isBlank($3)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";