// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\().*(.*)[ ]?==[ ]?null[ ]?\|\|[ ]?(.*).length\(\)[ ]?==[ ]?0").unwrap();
let string = "(companyId != null && companyId.length() > 0 )
(companyId != null && companyId.length() > 0 )
(campaignId == null || campaignId.length() == 0)";
let substitution = "$1StringUtils.isBlank($3)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}