# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\().*(.*)[ ]?==[ ]?null[ ]?\|\|[ ]?(.*).length\(\)[ ]?==[ ]?0/$1StringUtils.isBlank($3)/g;t' <<< "(companyId != null && companyId.length() > 0 )
(companyId != null && companyId.length() > 0 )
(campaignId == null || campaignId.length() == 0)"