const regex = /(\().*(.*)[ ]?==[ ]?null[ ]?\|\|[ ]?(.*).length\(\)[ ]?==[ ]?0/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\().*(.*)[ ]?==[ ]?null[ ]?\\|\\|[ ]?(.*).length\\(\\)[ ]?==[ ]?0', 'g')
const str = `(companyId != null && companyId.length() > 0 )
(companyId != null && companyId.length() > 0 )
(campaignId == null || campaignId.length() == 0)`;
const subst = `$1StringUtils.isBlank($3)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);