using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\().*(.*)[ ]?==[ ]?null[ ]?\|\|[ ]?(.*).length\(\)[ ]?==[ ]?0";
string substitution = @"$1StringUtils.isBlank($3)";
string input = @"(companyId != null && companyId.length() > 0 )
(companyId != null && companyId.length() > 0 )
(campaignId == null || campaignId.length() == 0)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}