re = /(\().*(.*)[ ]?==[ ]?null[ ]?\|\|[ ]?(.*).length\(\)[ ]?==[ ]?0/
str = '(companyId != null && companyId.length() > 0 )
(companyId != null && companyId.length() > 0 )
(campaignId == null || campaignId.length() == 0)'
subst = '$1StringUtils.isBlank($3)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result