import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\().*(.*)[ ]?==[ ]?null[ ]?\\|\\|[ ]?(.*).length\\(\\)[ ]?==[ ]?0";
final String string = "(companyId != null && companyId.length() > 0 )\n"
+ "(companyId != null && companyId.length() > 0 )\n"
+ "(campaignId == null || campaignId.length() == 0)";
final String subst = "$1StringUtils.isBlank($3)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}