import Foundation
let pattern = #"node\/([1-9]{1,10})\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<a href="/node/134358/publicar?destination=admin/dashboard/notas">No publicado</a>
<a href="/node/134358/publicar?destination=admin/dashboard/notas">Publicado</a>
<a href="/node/1/publicar?destination=admin/dashboard/notas">Publicado</a>
<a href="/node/1234567/publicar?destination=admin/dashboard/notas">Publicado</a>
<a href="/node/123456789/publicar?destination=admin/dashboard/notas">Publicado</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)