package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)node\/([1-9]{1,10})\/`)
var str = `<a href="/node/134358/publicar?destination=admin/dashboard/notas">No publicado</a>
<a href="/node/134358/publicar?destination=admin/dashboard/notas">Publicado</a>
<a href="/node/1/publicar?destination=admin/dashboard/notas">Publicado</a>
<a href="/node/1234567/publicar?destination=admin/dashboard/notas">Publicado</a>
<a href="/node/123456789/publicar?destination=admin/dashboard/notas">Publicado</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}