import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "node\\/([1-9]{1,10})\\/";
final String string = "<a href=\"/node/134358/publicar?destination=admin/dashboard/notas\">No publicado</a>\n\n"
+ "<a href=\"/node/134358/publicar?destination=admin/dashboard/notas\">Publicado</a>\n\n"
+ "<a href=\"/node/1/publicar?destination=admin/dashboard/notas\">Publicado</a>\n\n"
+ "<a href=\"/node/1234567/publicar?destination=admin/dashboard/notas\">Publicado</a>\n\n"
+ "<a href=\"/node/123456789/publicar?destination=admin/dashboard/notas\">Publicado</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}