using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"node\/([1-9]{1,10})\/";
string input = @"<a href=""/node/134358/publicar?destination=admin/dashboard/notas"">No publicado</a>
<a href=""/node/134358/publicar?destination=admin/dashboard/notas"">Publicado</a>
<a href=""/node/1/publicar?destination=admin/dashboard/notas"">Publicado</a>
<a href=""/node/1234567/publicar?destination=admin/dashboard/notas"">Publicado</a>
<a href=""/node/123456789/publicar?destination=admin/dashboard/notas"">Publicado</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}