re = /node\/([1-9]{1,10})\//m
str = '<a href="/node/134358/publicar?destination=admin/dashboard/notas">No publicado</a>
<a href="/node/134358/publicar?destination=admin/dashboard/notas">Publicado</a>
<a href="/node/1/publicar?destination=admin/dashboard/notas">Publicado</a>
<a href="/node/1234567/publicar?destination=admin/dashboard/notas">Publicado</a>
<a href="/node/123456789/publicar?destination=admin/dashboard/notas">Publicado</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end