#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)node\/([1-9]{1,10})\/"
Local $sString = "<a href="/node/134358/publicar?destination=admin/dashboard/notas">No publicado</a>" & @CRLF & _
"" & @CRLF & _
"<a href="/node/134358/publicar?destination=admin/dashboard/notas">Publicado</a>" & @CRLF & _
"" & @CRLF & _
"<a href="/node/1/publicar?destination=admin/dashboard/notas">Publicado</a>" & @CRLF & _
"" & @CRLF & _
"<a href="/node/1234567/publicar?destination=admin/dashboard/notas">Publicado</a>" & @CRLF & _
"" & @CRLF & _
"<a href="/node/123456789/publicar?destination=admin/dashboard/notas">Publicado</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")