use strict;
my $str = '<a href="/node/134358/publicar?destination=admin/dashboard/notas">No publicado</a>
<a href="/node/134358/publicar?destination=admin/dashboard/notas">Publicado</a>
<a href="/node/1/publicar?destination=admin/dashboard/notas">Publicado</a>
<a href="/node/1234567/publicar?destination=admin/dashboard/notas">Publicado</a>
<a href="/node/123456789/publicar?destination=admin/dashboard/notas">Publicado</a>';
my $regex = qr/node\/([1-9]{1,10})\//mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}