const regex = /node\/([1-9]{1,10})\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('node\\\/([1-9]{1,10})\\\/', 'gm')
const str = `<a href="/node/134358/publicar?destination=admin/dashboard/notas">No publicado</a>
<a href="/node/134358/publicar?destination=admin/dashboard/notas">Publicado</a>
<a href="/node/1/publicar?destination=admin/dashboard/notas">Publicado</a>
<a href="/node/1234567/publicar?destination=admin/dashboard/notas">Publicado</a>
<a href="/node/123456789/publicar?destination=admin/dashboard/notas">Publicado</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}