// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)node\/([1-9]{1,10})\/").unwrap();
let string = "<a href=\"/node/134358/publicar?destination=admin/dashboard/notas\">No publicado</a>
<a href=\"/node/134358/publicar?destination=admin/dashboard/notas\">Publicado</a>
<a href=\"/node/1/publicar?destination=admin/dashboard/notas\">Publicado</a>
<a href=\"/node/1234567/publicar?destination=admin/dashboard/notas\">Publicado</a>
<a href=\"/node/123456789/publicar?destination=admin/dashboard/notas\">Publicado</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}