import Foundation
let pattern = #"""
[^A-Za-z0-9-$_ ]|
"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
3340273*625-1076781-2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"a-zA-Z0-9@\$"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}