use strict;
my $str = '
3340273*625-1076781-2
';
my $regex = qr/[^A-Za-z0-9-$_ ]|
/p;
my $subst = 'a-zA-Z0-9@\\$';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";