# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"[^A-Za-z0-9-$_ ]|\n\n\n")
test_str = ("\n"
"3340273*625-1076781-2 \n")
subst = "a-zA-Z0-9@\\$"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.