# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^A-Za-z0-9-$_ ]|
/a-zA-Z0-9@\$/;t' <<< "
3340273*625-1076781-2
"