import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^A-Za-z0-9-$_ ]|\n\n\n";
final String string = "\n"
+ "3340273*625-1076781-2 \n";
final String subst = "a-zA-Z0-9@\\$";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}