re = /[^A-Za-z0-9-$_ ]|
/
str = '
3340273*625-1076781-2
'
subst = 'a-zA-Z0-9@\\$'
result = str.sub(re, subst)
# Print the result of the substitution
puts result