const regex = /[^A-Za-z0-9-$_ ]|
/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^A-Za-z0-9-$_ ]|
', '')
const str = `
3340273*625-1076781-2
`;
const subst = `a-zA-Z0-9@\$`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);