// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^A-Za-z0-9-$_ ]|
").unwrap();
let string = "
3340273*625-1076781-2
";
let substitution = "a-zA-Z0-9@\\$";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}