$re = '/[^A-Za-z0-9-$_ ]|
/';
$str = '
3340273*625-1076781-2
';
$subst = "a-zA-Z0-9@\$";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;