// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<a.*href=)["'](.*)["']"#).unwrap();
let string = "<h2><a href=\"http://www.google.com/test\">Link</a></h2>2014-54-22 22:23";
let substitution = "\\1\"http://localhost/down.php?u=urldecode(\\2)\"";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}