# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<a.*href=)[\"'](.*)[\"']"
test_str = "<h2><a href=\"http://www.google.com/test\">Link</a></h2>2014-54-22 22:23"
subst = "\\1\"http://localhost/down.php?u=urldecode(\\2)\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.