use strict;
my $str = '<h2><a href="http://www.google.com/test">Link</a></h2>2014-54-22 22:23';
my $regex = qr/(<a.*href=)["'](.*)["']/mp;
my $subst = '\\1"http://localhost/down.php?u=urldecode(\\2)"';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";