const regex = /(<a.*href=)["'](.*)["']/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a.*href=)["\'](.*)["\']', 'm')
const str = `<h2><a href="http://www.google.com/test">Link</a></h2>2014-54-22 22:23`;
const subst = `\1"http://localhost/down.php?u=urldecode(\2)"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);