#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<a.*href=)["'](.*)["']"
Local $sString = "<h2><a href="http://www.google.com/test">Link</a></h2>2014-54-22 22:23"
Local $sSubst = "\1"http://localhost/down.php?u=urldecode(\2)""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)