import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a.*href=)[\"'](.*)[\"']";
final String string = "<h2><a href=\"http://www.google.com/test\">Link</a></h2>2014-54-22 22:23";
final String subst = "\\1\"http://localhost/down.php?u=urldecode(\\2)\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}