# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a.*href=)["'](.*)["']/\1"http:\/\/localhost\/down.php?u=urldecode(\2)"/m;t' <<< "<h2><a href=\"http://www.google.com/test\">Link</a></h2>2014-54-22 22:23"