$re = '/(<a.*href=)["\'](.*)["\']/m';
$str = '<h2><a href="http://www.google.com/test">Link</a></h2>2014-54-22 22:23';
$subst = "\1\"http://localhost/down.php?u=urldecode(\2)\"";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;