using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a.*href=)[""'](.*)[""']";
string substitution = @"\1""http://localhost/down.php?u=urldecode(\2)""";
string input = @"<h2><a href=""http://www.google.com/test"">Link</a></h2>2014-54-22 22:23";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}