import Foundation
let pattern = #"PTK(\+[:a-zA-Z0-9]*){2}\+([0-9]{6})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
PTK+++++US'&
PTK+++250515'&
PTK+++250515++US'&
PTK+:::::::::700++220610'&
PTK++:::::::::700+220610'&
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}