$re = '/PTK(\+[:a-zA-Z0-9]*){2}\+([0-9]{6})/';
$str = 'PTK+++++US\'&
PTK+++250515\'&
PTK+++250515++US\'&
PTK+:::::::::700++220610\'&
PTK++:::::::::700+220610\'&';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);