#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "PTK(\+[:a-zA-Z0-9]*){2}\+([0-9]{6})"
Local $sString = "PTK+++++US'&" & @CRLF & _
"PTK+++250515'&" & @CRLF & _
"PTK+++250515++US'&" & @CRLF & _
"PTK+:::::::::700++220610'&" & @CRLF & _
"PTK++:::::::::700+220610'&"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")