use strict;
my $str = 'PTK+++++US\'&
PTK+++250515\'&
PTK+++250515++US\'&
PTK+:::::::::700++220610\'&
PTK++:::::::::700+220610\'&';
my $regex = qr/PTK(\+[:a-zA-Z0-9]*){2}\+([0-9]{6})/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}