import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "PTK(\\+[:a-zA-Z0-9]*){2}\\+([0-9]{6})";
final String string = "PTK+++++US'&\n"
+ "PTK+++250515'&\n"
+ "PTK+++250515++US'&\n"
+ "PTK+:::::::::700++220610'&\n"
+ "PTK++:::::::::700+220610'&";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}