re = /PTK(\+[:a-zA-Z0-9]*){2}\+([0-9]{6})/
str = 'PTK+++++US\'&
PTK+++250515\'&
PTK+++250515++US\'&
PTK+:::::::::700++220610\'&
PTK++:::::::::700+220610\'&'
# Print the match result
str.match(re) do |match|
puts match.to_s
end