using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"PTK(\+[:a-zA-Z0-9]*){2}\+([0-9]{6})";
string input = @"PTK+++++US'&
PTK+++250515'&
PTK+++250515++US'&
PTK+:::::::::700++220610'&
PTK++:::::::::700+220610'&";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}