package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`PTK(\+[:a-zA-Z0-9]*){2}\+([0-9]{6})`)
var str = `PTK+++++US'&
PTK+++250515'&
PTK+++250515++US'&
PTK+:::::::::700++220610'&
PTK++:::::::::700+220610'&`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}