const regex = /PTK(\+[:a-zA-Z0-9]*){2}\+([0-9]{6})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('PTK(\\+[:a-zA-Z0-9]*){2}\\+([0-9]{6})', '')
const str = `PTK+++++US'&
PTK+++250515'&
PTK+++250515++US'&
PTK+:::::::::700++220610'&
PTK++:::::::::700+220610'&`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}